This project has moved and is read-only. For the latest updates, please go here.

Issues starting the tool and connecting to TFS

Sep 11, 2013 at 3:58 PM

I came across this tool just today and downloaded both the latest releases. The reason being we have a unique situation where we are using VS2012 as our user interface but the TFS server that we are connecting to is TFS2010. In this situation I am not sure which version of your tool to use.

I tried starting both, and it errors out saying "Could not load previous TFS connection" . When I click on the "not connected" button to re-connect or establish connection to TFS it completely crashes with this message -
"Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified."
From one of the earlier discussions, I saw that deleting the HKCU\Software\Lonza\TestEditor may fix the issue, but I do not even see that key in my regedit.

So, at this point I am at a roadblock. Can you point me in the right direction?
Sep 11, 2013 at 4:32 PM

Did you get the above error when you ran the 2012 build of the tool?

In general, you have to run the build of the tool that matches the version of Visual Studio installed on your local machine, because that is what supplies the TFS client API assemblies. If you have multiple Visual Studio versions installed, run the build of the tool that matches your TFS version.

If you still run into issues, you can install the standalone TFS2010 client object model ( and run the 2010 version of the tool.

Hope this helps,
Sep 11, 2013 at 6:19 PM
Hi Aidan,

After installing the TFS2010 client object model I am now able to run the 2010 version of the Test Steps Editor.
Thanks for all the help.

Sep 11, 2013 at 6:23 PM
Thanks. Just curious, what error did you get when you ran the 2012 build of TFS Test Steps Editor?
Sep 11, 2013 at 6:41 PM

Before installing the TFS2010 Client Object Model, I got the same error when I ran both versions of the TFS Test Steps Editor (2010 & 2012).
And that 's what did not make a lot of sense to me, as I was expecting one of them to work.
The error from the log is below.

And here's an interesting bit: I had another team member install and run TFS Test Steps Editor (2010 version) on a different machine which has VS2010 + TFS2010, but the tool just crashed at launch without any error messages.
2013-09-11 08:46:04.1904 | 1 | INFO | TestStepsEditor.Program | Application Start 
2013-09-11 08:46:04.3034 | 1 | INFO | TestStepsEditor.Preferences.PreferenceCollection | Load preferences from registry at Software\TestStepsEditor 
2013-09-11 08:46:04.3034 | 1 | INFO | TestStepsEditor.MainForm | Apply display preferences. 
2013-09-11 08:46:17.0254 | 1 | INFO | TestStepsEditor.MainForm | Change project. 
2013-09-11 08:46:17.0254 | 1 | FATAL | TestStepsEditor.ExceptionReporter | Reporting Exception System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.TeamFoundation.Client, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
   at TestStepsEditor.Preferences.UserPreferences.LoadProjectSelectionFromUser()
   at TestStepsEditor.MainForm.ChangeProjectButton_Click(Object sender, EventArgs e) in d:\_git\TFSTestStepsEditor\Trunk\TestStepsEditor\MainForm.cs:line 444
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripButton.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.Run(Form mainForm)
   at TestStepsEditor.Program.Main() in d:\_git\TFSTestStepsEditor\Trunk\TestStepsEditor\Program.cs:line 26
Sep 15, 2013 at 8:51 PM
Thank you for the details. When I created the first 2012 build I adjusted the target versions of the TFS references but after cracking open TestStepsEditor.exe in Reflector it still picked up the 2010 references. After removing and re-adding the references by browsing to the 2012 PrivateAssemblies, I see the correct versions referenced now.

I replaced the 2012 build with a new one -- if someone can give it a try on a system with only VS2012 (no 2010 client) it would be greatly appreciated.

Apologies for the issues!
Sep 18, 2013 at 4:29 PM

Just this morning I downloaded your new build for the VS2012 interface, and made sure to un-install the standalone TFS2010 client object model.
This build works just perfectly. Thank you for your response and your quick changes.

Re-iterating my configuration for anyone who may face similar issues:
  • Visual Studio - 2012
  • TFS Server - 2010
  • Test Steps Editor - 210_2012
Sep 18, 2013 at 4:32 PM

Great! Thank you for testing!